Как очистить все реквизиты и табличные части документа

Бывает необходимо программно очистить все  табличные части и реквизиты документа.
Ниже приведена процедура очистки любого документа

Процедура ОчиститьДокумент(Документ)
    Для Каждого
Рек Из Документ.Метаданные().Реквизиты Цикл
       
Документ[Рек.Имя]=Неопределено;
    КонецЦикла;
    Для Каждого
Тч Из Документ.Метаданные().ТабличныеЧасти Цикл
       
Документ[Тч.Имя].Очистить();
    КонецЦикла;
КонецПроцедуры

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *